This happened when trying to check a Seagate hard disk on an Acer TravelMate 5512 with SeaTools for DOS v2.20. Symptoms:

  • The SeaTools bootable CD booted ok, and the initial SeaTools interface showed up with a licence acceptance screen.
  • Mouse was shown as installed as “PS/2” during the FreeDOS boot.
  • No mouse or keyboard input works. This also applies when booting up with a USB mouse connected.
  • Ctrl+Alt+Del brings one back to the DOS level, and here the keyboard works.

This seems to be an old unfixed problem on some systems, see for example forum discussions here and here.

Workaround: this problem appears only on some systems, not on all. So I simply switched the hard disk into a different computer (ThinkPad T60), and here mouse and keyboard work.

One thought on “How to fix non-working mouse and keyboard in SeaTools for DOS 2.20?

  1. I had the same problem. The copy of Seatools on Hiren’s bootcd worked fine. (Both text and gui versions)

Leave a reply

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>